It is possible to compute data from videos in the Edit workspace by using the combination of a measurement tool, a marker with tracking activated and a data table. The computed data can then be extracted as a csv and used in other analytical software.

  1. Distance between two points
  2. Anlge tracking

Distance between two points

In the following example, you will see how to calculate the distance between the foot and the back of a cyclist. The same features can be applied to any video, as long as the camera is fixed (fixed position and no PTZ moveements), the target can be represented on a 2-dimensional plane and the points you want to track can be distinguished easily on the video (tip: to improve the reliability of the tracking, place amarker of a flashy color on those points)


  1. In the Edit workspace, start a new montage and add your video in the montage items list
  2.  Select the drawing tool Marker and place it on the feet of the cyclist .
  3.  Right click on the added Marker, select Tracking and choose the speed of the targeted point during the video playback.
  4. Select the Marker drawing tool and place it on the back of the cyclist.
  5. Use the drawing tool Measure to define a reference point on the video (tip: the default measure is 1 meter. Right-click > Set as reference to change the value. Tools > Options > Analyzer to change the unit).
  6.  Add the drawing tool Data Table on your video
  7. Select the Data table, press on CTRL and select the two markers
  8. Right-click on the Data Table and select "Display distance between 2nd and 3rd drawing in this column"
    1. "Display offset (dX, dY)..." shows the horizontal and vertical distance between the two markers
    2. "Display offset dX..." shows the horizontal distance betwee the two markers
    3. "Display offset dX..." shows the vertical distance between the two markers
  9. Choose the frequencies of the entries in the data table and click on OK. In this example, as the video has 60 frames per second, a new entry every 30 fields is equivalent to 2 entries per second
  10. You can add more columns in the data table, that will automatically calculate relationships between entries. Right.click on the data table and select Insert column
    1. Interval speed: difference between current entry and previous entry
    2. Average speed: average of all the interval speed
    3. Interval length: distance between two entries
    4. Interval duration: time between to entries
    5. Data: another distance or position from another point
    6. Text: a free text field addition for labels or notes
  11. To export the data as a csv, right-click on the table and select Export Data

 

Angle tracking

The data table can also retrieve the data from an angle. The processus is very similar to the distance between two points.

  1.   Place an angle on the video
  2. Once the angle is positionned correctly, right-click on it and select Tracking > Slow/Medium/Fast speed
  3. Add a data table
  4. Select the data table, press on Ctrl and select the angle
  5. Right-click on the Data column and select Display angle